Symptom
- When a candidate makes a change or saves their profile the business rule associated to the candidate profile is not getting triggered.
- When the recruiter makes a change to the candidates profile the rules do get triggered.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Access the Candidate Profile via External Career Site
- Take the action to trigger the rule
- You will notice the rule won't be triggered
Cause
Mobile Apply is enabled.
Resolution
This is expected behavior. The system does not trigger business rules on Mobile apply screens for both External and new Internal Career Site powered by CSB.
However, when a recruiter makes changes in a candidate profile and saves them, the rules are triggered in the web application, as it is a non-Mobile Apply screen.
The product management team, along with engineering are hoping to enable business rules for mobile apply in a future release. Currently at this time no time frame has been provided on when this will be added.
Please see the following Enhancement Request with in the community portal here
See Also
2515173 - Rules Engine in Recruiting Management - Recruiting Management
2540395 - How To Enable Recruiting Mobile Apply
Keywords
mobile, apply, rule, candidate, profile, recruiter, onSave , KBA , LOD-SF-RCM-RUL , Recruiting Rule Issues with MDF Platform , Problem