SAP Knowledge Base Article - Public

2782194 - Custom Email Notification is not Being Sent for an EC Alert

Symptom

A custom email notification is configured in our workflow to be sent for an EC alert rule. The alert is getting created but no email is being sent.

Environment

  • SAP SuccessFactors Employee Central - Alerts and Notifications
  • SAP SuccessFactors Employee Central - Workflow & Trigger

Reproducing the Issue

  1. Create a business rule to trigger an EC alert and notification.
  2. In the workflow, assign a custom email under 'Workflow Email Configuration' or 'Email Template Group'.
  3. When the rule is triggered, an alert gets created but no email notification is sent.

Cause

Custom emails are not supported for EC Alerts. The system builds the mail notification based on the alert message header and content.

Resolution

Do not assign a custom email under 'Workflow Email Configuration' or 'Email Template Group' in your workflow for an EC Alert rule. The system will build the mail notification.

See Also

  • 2315275 - Employee Central - Workflows & Alerts
  • 2156278 - How to set up EC Alerts and Notification using Business Rules

Keywords

Alert, Email, Workflow, Notification, Custom, Rule, Workflow Email Configuration , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC , Employee Central , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem

Product

SAP SuccessFactors Employee Central 2305