SAP Knowledge Base Article - Public

2782313 - Notification Workflow Rule Not Sending Notification to the Lead's Owner

Symptom

You have created a Workflow Rule to send a notification to the Owner of the Lead based in some conditions. For that, you have maintained the Sales Responsible Employee as recipient in the workflow rule configuration.

However, the workflow rule is not sending the notification to the Owner of the Lead when the conditions are met.

Environment

SAP Cloud for Customer

Reproducing the Issue

In this example, we will consider a Workflow Rule to the Lead object with condition, field "Owner" not equal to "Created By", to send a notification to the lead's Owner when the condition is met.

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Click on New button.
  4. Create a lead with the Owner different than the current user (Created By).
  5. Save the lead.
  6. The user define as the Owner of the lead, is not receiving the notification from the workflow rule, even though the condition is met.

Cause

The workflow rule is not sending the notification to the lead's Owner because the Sales Responsible Employee maintained as recipient in the workflow configuration stands to the field "Owner (Sales)" of the Lead and not the field "Owner".

Resolution

To send the notification to the lead's Owner, you should maintain the Marketing Responsible Employee as recipient in the workflow rule configuration. Because in the Lead object, the Marketing Responsible Employee stands to the Owner field.

Keywords

Notification Workflow Rule, Lead Owner, Marketing Responsible Employee, Sales Responsible Employee , KBA , LOD-LE-MKT-LEA-ANA , Lead Analytics , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions