Symptom
Gateway timeout error on generating matrix report v12
Environment
SuccessFactors BIZX: Succession Management and matrix report v12
Reproducing the Issue
-
Go to Performance-Potential matrix via Succession
-
Click Generate Report button-> gives Gateway Timeout error
Cause
One of the common reasons for this issue is incorrect configuration of matrix report filters.
Resolution
If incorrect matrix filters is configured for matrix reports then it will result in many issues like Gateway Timeout error, users won't show up in the report, etc.
Below wiki page contains list of supported matrix report filters:
https://wiki.scn.sap.com/wiki/display/SAPSF/Matrix+Grid+Reports+-+Custom+Filters
If you see any other field (other than mentioned in Supported field list) as matrix filter in your matrix report, example empId then you need to contact either Cloud Product Support or Implementation Partner to correct the xml configuration.
Keywords
matrix report error, Gateway Timeout error in matrix report v12 , KBA , LOD-SF-SCM-MXG , Matrix Grid Reports (9 Box) , Problem