Symptom
Some company's outsourced/hourly employees aren't receiving the Forget Password Email Notification.
Environment
SuccessFactors HCM Suite
Cause
The user record inside the User Data File (UDF) doesn't have an email address registered in the "EMAIL" column. Since this field is blank and it's the main email address for the SuccessFactors System, the user isn't able to receive any SuccessFactors Notification.
Resolution
At first, it's important to emphasize that, whether or not the user have a business email adresss granted by the company (with the company domain, for example), any other email that he has, regardless the account provider (@outlook, @gmail or any other), must be populated inside the Company's User Data File (UDF). The steps bellow will show how to populate the email address inside the UDF file in order to make the user able to receive the Forget Password Notifications and any other.
- Login in your SuccessFactors Instance, preferentially, as an admin;
- At the Home Page, in the Search Tool Box, search for the "Employee Export" feature;
- Click in the button named "Export User File" so the download will begin;
- A zip folder will be downloaded. Just extract the folder anywhere in the computer, and open the Excel Format file (.csv) inside the folder;
- Once the file is in the .csv format, the data is populated in one column only. In order to find the fields easily, split the data in columns through the function "Text to Columns" located in the Excel "Data" menu;
- First, find the user line using any criteria you wish (username, user ID, etc.);
- Then, find the column called "EMAIL", and, as the final step inside the file, set the user email in the respective cell;
- Save and close the file;
- Get back to the SuccessFactors and search for the "Employee Import" feature;
- Upload the file that you've changed in the earlier steps, and click in the "Import User File" button;
- Now, the user should be able to receive any Email Notification that could be configured to him.
Please note that this KBA only shows how to grant a valid SuccessFactors email address to the user. There are other configurations that may have impact in these notifications and should be checked, like either Admin Center Email Notifications configuration and RBP Permission Groups. This additional configurations could be reviewed in order to ensure that the user is enabled to receive SuccessFactors Notifications and also have this right granted in the RBP Permission Groups in which he's inside.
See Also
2087890 - Email Notifications: Top Reasons Why Emails are Not Sent or Received
2087929 - Forget Password Notification - Tips
Keywords
Email Notifications, Forget Password, business email, UDF. , KBA , LOD-SF-PLT-NOT , Email Notifications , How To