SAP Knowledge Base Article - Public

2784816 - Wrong Format for Files Downloaded From SAP S/4HANA Cloud

Symptom

Files downloaded from Identity and Access Management (IAM) apps like Maintain Business Users will appear to be poorly formatted when viewed in Microsoft Excel

Environment

  • SAP S/4HANA Cloud 1902

Reproducing the Issue

  1. Go to an IAM app
  2. Click on Download to download some data from the list of results in the IAM app
  3. Open the .CSV file that is downloaded in Microsoft Excel
  4. At this point the file may appear to be be poorly formatted 

Cause

  • IAM apps will create a .CSV file using the semicolon ";" as the separator
  • If the Regional and Language settings in your computer are set to use a comma "," as the separator for files then Microsoft Excel will not consider the semicolon to separate values

Resolution

  • Use the Import Wizard in Microsoft Excel to import the CSV into Excel instead of opening the CSV file directly
    • This will allow you to specify the delimiter you want to use after you select the file you want to import
    • Ensure that you specify semicolon as this is the separator used when downloading the file
  • Alternatively, you can follow Microsoft documentation to change the separator to ";" so that Excel will format the file correctly

See Also

External - Import or export text (.txt or .csv) files

Keywords

comma semicolon , ; Maintain Business User Maintain Business Roles Download for IDP Download Users Download Changes Download User Role Assignments Regional and Language Import Wizard delimiter separator , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 1902