Symptom
You perform layout adaptation and add the e-mail Viewer tab to the E-Mail TI (Thing Inspector), however, the tab is not displayed.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Activities work center.
- Go to the E-mails work view.
- Open the e-mail ID 123 (123 represents the ID).
- Click Adapt.
- Select Edit Master Layout option.
- Hover the mouse over the tabs location.
- Click Add Items and the Additional Tab pop-up will open.
- Select the E-mail Viewer and click Apply.
- End the Adaptation and open the E-Mail.
Result: The E-mail Viewer tab is not displayed.
Cause
There can be several reasons:
- The E-mail Viewer tab does not appear if the e-mail does not have HTML content available.
- Only E-mails created and synchronized after the 1905 upgrade have displayable content stored.
- E-mails sent from non-converted Leads will not have the tab displayed.
- Currently, this feature is only enabled for e-mails coming from Groupware, created via the Accounts WC or sent from converted Leads.
- This feature is currently not available on Internet Explorer but will be enabled for future release. Please use Google Chrome to see the e-mails until then. Please note SAP Support team cannot provide and exact date/release at this time.
Resolution
Please make sure that the e-mail you are viewing checks against the points in the Cause section.
E-Mails that do not fulfill that criteria will not display the E-Mail Viewer tab.
After enabling the E-Mail viewer facet, it will only be visible for e-mails where content exists of a type, which will show in that view.
If you have an e-mail which shows empty in the e-mail Overview facet, check if there is content in the e-mail viewer.
See Also
SAP Help Portal: View E-Mails with Original Formatting and Structure
Keywords
E-mail Viewer, e-mail, Fiori UI, HTML5 , KBA , email viewer , LOD-CRM-ACT , Activities , How To