SAP Knowledge Base Article - Public

2785893 - A report with custom member as filter is not showing the same result for admin users - Workforce Analytics

Symptom

A WFA report with custom member as filter is not showing the same result for admin users that should have permission to all the data in the system

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SuccessFactors Workforce Analytics (ANA) - All versions
SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Create a WFA report and add custom members as filters
  2. Share the report with two admin users who have different permissions in Tree Security
  3. One user can see the correct result in the report e.g. Headcount of 4,000 users
  4. The other user is seeing a different value in the result e.g. Headcount of 14,000 users

Cause

The Tree Security of the second user is restricting the access to the data that was configured in the custom member. Instead of having permission in Tree Security to "All", he has a Horizontal or Open Ended restriction to All.

horizontal.png

Therefore, the filter is not getting applied when this user runs the report.

Resolution

If the user is an admin who should have access to all the data, change the Tree Security permission of the user to "All".
All.png

See Also

2779479 - Role based security issue or blank result in WFA report with custom member and scorecard - Workforce Analytics

2366301 - Range Types in WFA Tree Security

2371918 - Custom Member filter is not working or it is not available for some users

Keywords

KBA , LOD-SF-WFA , Workforce Analytics & Planning , How To

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Workforce Analytics all versions