SAP Knowledge Base Article - Public

2787186 - Account relationships are shown twice

Symptom

You want to add a relationship to an account, but one or more relationships are shown twice in the dropdown menu.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open the account 123 (123 represents the ID of the account).
  4. Navigate to the Relationships facet.
  5. Click Add button.
  6. Open the dropdown menu for the Relationship Type field.

Relationship ABC (ABC represents the description of the relationship) is shown twice.

Cause

Relationship ABC was created as a directional relationship. Example for a directional realtionship would be Has Contact Person and Is Contact Person For.

Resolution

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. Search and open the activity General Business Partners.
  4. Enter the submenu Maintain Relationships.
  5. Search for relationship ABC.
  6. Untick the checkbox Directional Relationship.
  7. Save.

 Now the reverse direction is removed and the relationship is shown only once in the Relationship Type dropdown menu.

Keywords

Account, Contact, Relationship, Duplicate , KBA , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions