Symptom
You want to add a relationship to an account, but one or more relationships are shown twice in the dropdown menu.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Open the account 123 (123 represents the ID of the account).
- Navigate to the Relationships facet.
- Click Add button.
- Open the dropdown menu for the Relationship Type field.
Relationship ABC (ABC represents the description of the relationship) is shown twice.
Cause
Relationship ABC was created as a directional relationship. Example for a directional realtionship would be Has Contact Person and Is Contact Person For.
Resolution
-
Go to the Business Configuration work center.
- Go to the Overview view.
- Search and open the activity General Business Partners.
- Enter the submenu Maintain Relationships.
- Search for relationship ABC.
- Untick the checkbox Directional Relationship.
- Save.
Now the reverse direction is removed and the relationship is shown only once in the Relationship Type dropdown menu.
Keywords
Account, Contact, Relationship, Duplicate , KBA , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions