Symptom
You migrate Accounting Transaction Data: Bank Balance. In the simulation step, you receive the error message:
.Bank statement ID 0 for bank account ID rejected.
.No b.acct. active on dd.mm.yyyy for IBAN <IBAN>, nat.b.c. <national bank code>, and currency <currency> found..
.Bank account missing or cannot be determined.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Go to the Overview view.
- Show All Configuration Elements.
- Search for the activity "Migration of accounting transaction data".
- Open the activity.
- Select Migrate accounting transaction data using the migration tool.
- Select the migration instance XXX (XXX stand for the migration instance).
- Select Execute Migration.
- Select the file ABC (ABC stands for the source file to be migrated).
- Select Process File.
In the simulation step, you have the error messages:
.Bank statement ID 0 for bank account ID rejected.
.No b.acct. active on dd.mm.yyyy for IBAN <IBAN>, nat.b.c. <national bank code>, and currency <currency> found.
.Bank account missing or cannot be determined.
Cause
There are two possible reasons:
1. There are inconsistencies with the data maintained in the migration file with the data maintained in the Bank Directory. Most probably, you have maintained the BIC in the column National Bank Code in the file.
Or
2. There are several line items have the same bank account number.
Resolution
1. Ensure that all data such as the IBAN or the National Bank Code maintained in the migration file are the one maintained in the Bank Directory.
2. A unique identifier for the bank account number is needed, which can be achived by appending the currency/other identifiers in English to these same bank account numbers.
See Also
2558477 - Bank Statement Upload: Bank Account Missing or Cannot be Determined
Keywords
Bank Balance Migration, National Bank Code, Bank Account, Extrait de Compte, Compte Bancaire Manquant. , KBA , AP-PAY-BS , Bank Statement , Problem