Symptom
You have added a Product (spare part) to the Line Item of the Service Order, but when you try to change the Ship-From value, the field is greyed out.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Select the Service Orders Processing view.
- Select Line Item for the relevant Service Order.
- Click on the Edit button.
- Navigate to the Services and Spare Parts tab.
- Select the relevant Line Item.
- Go to the Spare Part Logistics sub-tab.
- You can see under Shipping that the Ship-From field is greyed out.
Cause
You have maintained in the Product (spare part) master data the Item Group as DIGI - Spare part - direct goods issue for the Sales Organization.
If you maintain the Item Group DIGI - Spare part - direct goods issue, it is the system expected behavior to deactivate the field for Ship-From address. The system will in this case automatically select the most appropriate Site maintained in the Material master data for affected product.
The system only allows the Ship-From address to be editable for SHIP - Spare part (advanced shipment/sales) and PICK - Spare part (engineer pick-up/sales) Item Groups. The system is therefore behaving expectedly.
Resolution
If you want to have the field editable, we recommend that you maintain the appropriate Item Group in the Product master data. Please follow the following steps to do that:
- Go to the Product and Service Portfolio work center.
- Select the Products view.
- Select the Product ID XYZ (XYZ represents the ID of the spare part).
- Click the Edit button.
- Navigate to the Sales tab.
- Go to Sales subtab.
- Change the Item Group for one of the following options:
SHIP - Spare part (advanced ship/sales)
PICK - Spare part (engineer pick-up/sales) Item Groups.
Keywords
Service Order; Item; Ship-From; Grayed Out; DIGI; PICK - Spare Part; SHIP - Spare Part , KBA , AP-SVO-SO , Service Order , How To