Symptom
When trying to set up a default Signature in My Email Settings, you get the following Information Message:
'You are not authorized to change the data.'
Environment
SAP Cloud for Customer
Reproducing the Issue
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Logon to your tenant.
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Select your Profile Icon.
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Select Settings.
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Select My Email Settings.
You see the following Information Message:
'You are not authorized to change the data.'
RBAM No Authorization
Cause
The logged in User does not have any or no write access for Sales and Service Templates.
Resolution
To be able to make changes in My Email Settings, the User needs to have Write Access to at least one of the Templates views - Service or Sales Templates.
- Go to the Administration work centre.
- Go to the General Settings view.
- Either open the relevant Business Role and click 'View All' or select your user and click Edit -> Access Rights.
- In the facet Work Centers and Views, click Find and search for Template*.
- Add access to either the view: 'COD_SALES_WCF - Sales - COD_TEMPLATE_WCVIEW - Templates' and/ or the view 'COD_SEOD_AGENT_QUEUE_WCF - Service - COD_SEOD_TEMPLATE_WCVIEW - Templates'.
- Go to the Access Restrictions facet.
- Grant Write Access for your user.
- Save your changes.
- Log out and back in for the changes to reflect on your user.
Keywords
You are not authorized to change the data Service Sales Template My Email settings E-Mail setting; RBAM; No Authorization for; BoNodeProxy; , KBA , LOD-CRM-SRP , Service Request Processing , Problem