SAP Knowledge Base Article - Public

2788665 - State Drop-Down List Does Not Show All States Available In The System

Symptom

In the Contacts OWL Advanced Search view, you notice that not all states are available when you first open the drop-down list.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work centre.
  2. Go to the Contacts view.
  3. Click 'Advanced Search'.
  4. Expand the list for the State field.
  5. You notice, that states from certain countries, are missing. For example: No German states are showing.

States.jpg

Cause

There are several countries maintained in the system, which each have a list of available states. Displaying the full list each time the state list gets expanded would take up unnecessary system performance.

Resolution

To find the state you are looking for, either select the country in the country field first, or start typing the state's name in the state field.

Keywords

Baden-Würtemberg, Bundesland fehlt, Ansprechpartner , KBA , LOD-CRM-CON , Contact , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1905