Symptom
Following the completion of the migration from Legacy Picklists to MDF Picklists, several inactive picklist values could still be available for selection in the search criteria while conducting the user search via the Talent Search tool in the Succession Module.
Environment
SAP SuccessFactors Succession
Cause
After migration from Legacy to MDF Picklists, inactive values that appear in Talent Search were migrated over while in OBSOLETED or ACTIVE status.
Resolution
In order to verify the Legacy Status for picklist values prior to migration take the following steps:
- Go to Admin Center
- Select Company Settings > Configure Object Definitions
- In the search drop downs choose "Object Definitions" and "PickListValue"
- Click Take Action > Make Correction
- Locate the field "legacyStatus" and click details
- In the Visibility section, ensure that the status is set to Editable. If it is not, change it to Editable.
- Once this is complete the ability to access the Legacy Statuses can be done via Picklist Center or exporting the Picklist via Import and Export Data
When reviewing the legacy values you will most likely see numbers for the legacyStatus (SF_FIELD4") column:
- DELETE = SF_FIELD4 = "2"
- ACTIVE = SF_FIELD4 ="0"
- OBSOLETED=SF_FIELD4 ="1"
If the inactive values appearing in Talent Search are either in ACTIVE or OBSOLETED status, it confirms the behavior as to why they appear in Talent Search.
The only way to ensure inactive picklist values that came in ACTIVE or OBSOLETED status can be removed from Talent Search would be to delete them via the Picklist Center:
- Navigate to the Picklist Center via Admin Center
- Choose the appropriate picklist ID
- Click "Insert New Record"
- Ensure you are using the current date to preserve the history of the previous effective dated record
- Make it inactive by clicking on the deactivate icon
Note: When performing this action it is important to ensure there are no employees (active or inactive) that have recordings of the inactive values because they can be deleted.
See Also
KB article 2537488 - Best Practice to Delete/Inactivate a Picklist or Picklist Value
Keywords
sf, success factors, SCM, pick list, Inactive Picklist Values, Delete Value, remove, Picklist Migration, Legacy Status, SCM-12760 , KBA , LOD-SF-SCM-TS , Talent Search , Problem