Symptom
I receive a "No Knowledge base articles available" message when accessing the Knowledge Base section in SAP Jam.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Jam Collaboration
Reproducing the Issue
1. User clicks on the Knowledge Base section from the global navigation bar.
2. The message is displayed to the user.
Cause
Knowledge Base articles will be displayed in this section based on the content that the user has viewed. e.g. Wikis, Blogs, Knowledge Articles. It would generally try to get 10 unique recently viewed contents as the input params to analyze.
If the user hasn't viewed contents lately (note that the contents must be analyzable contents like "blogs", "articles" and "pages" instead of others like "people" or "groups"), it won't return results in the section.
There are also cases that the viewed contents are totally irrelevant so the recommended KB won't be returned.
Note: There is a 2 hour delay before content will be displayed to the user in this section.
Resolution
User can do the following:
- View analyzable contents like "blogs", "articles" and "pages"
- After logging into the SAP Jam instance and viewing some content, the user needs to wait 2 hours before content will appear in the recommended section.
Keywords
recommended, recommendation, KB, KBA, JAM, knowledge based articles, available, widget, blog, article, page, cache , KBA , LOD-SF-JAM-KNB , Knowledge base Issue , LOD-SF-JAM , SAP Jam , Problem