Symptom
When the approving manager tries to release the 'Service Entry Sheets' from their My Inbox APP, nothing happens, after choosing 'Approve' the document remains in the Inbox. In the system log, error message 'Update was cancelled - workitem is not a user decision' is visible.
or
Approver sees below error after choosing 'Approve'
'You are not authorized for activity "Accept" for Purchasing Organization XXXX'
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a Service Purchase Order (Manage Purchase Orders)
- Create a Service Entry Sheet (Manage Service Entry Sheets - Lean Services)
- The Service Entry Sheet is marked for approval and sent to the inbox of the approving manager.
- The approving manager accesses 'My Inbox'.
- Approve the Service Entry Sheet, but it remains in the Inbox and Error appears.
Cause
Missing Authorisations
Resolution
Approvers of 'Service Entry Sheets' - need a business role containing the authorization objects:
- M_MSEG_BWE (Activity = 01; Goods Movement Type = 101, 102)
- M_MSEG_WWE (Activity = 01; Plant = *)
- M_SES_EKG (Activity = 03, 37, 74; Purchasing Group = *)
- M_SES_EKO (Activity = 03, 37, 74; Purchasing Organization = *)
- M_SES_WRK (Activity = 03, 37, 74; Plant = *)
The activity '*' or '37'(Accept).
So to overcome this issue,assign business role: SAP_BR_PROJ_MANAGE_COMM to your approving user or assign business catalog SAP_MM_BC_SES_WIAPPROVE_PC to an existing role of the user.
See Also
Keywords
SAP_APS_SAP_WFRT_APP, /IWWRK/BADI_WF_BEFORE_UPD_IB, CL_MM_PUR_SES_APPR_ACTION_BADI, AUTHORITY-CHECK, /iwwrk/mc_wf_rt_ib022, BR_PROJ_MANAGE_COMM.You are not authorized for activity "Accept" for Plant,You are not authorized for activity "Accept" for Purchasing Group,You are not authorized for activity "Accept" for Goods Movement Type , KBA , MM-PUR-SVC-SES , Service Entry Sheet for Service Procurement , Problem