Symptom
We have created duplicates in one or more of the background data blocks in the instance. How can we fix this?
Environment
SuccessFactors Employee Profile
Cause
This could have been caused by selecting the option to do an I by mistake, when you meant to use Import by overwriting existing data.
Resolution
A new job of "Delete Duplicate Background Data" is now available to be scheduled to run in the backend. This job is used to delete duplicate background data records. When all columns are the same for multiple records, only the latest updated record is retained. Once the job is done, an e-mail notification is sent to the Job Owner.
Its important noting that this won't work with attachment blocks, as even if you run the same import job twice, currently the attachments will have different id each time they are imported, which will make them be considered different entries.
This job requires to be scheduled either by a Support Representative, or an Implementation partner with access to Provisioning.
See Also
This works only for background data. In case you want remove duplicate data that is Trend Data, see 2091409 - Import & Export Process for Extended User Information in SuccessFactors HXM Suite
Keywords
Remove Duplicates; Duplicate Data; Duplicate Records; Background Portlets; Live Profile Import; , KBA , LOD-SF-EP-BGD , Background Elements , Product Enhancement