Symptom
We have created duplicates in one or more of the background data blocks in the instance. How can we fix this?
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
-
SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Profile
Cause
This could have been caused by selecting the option to do an I by mistake, when you meant to use Import by overwriting existing data.
Resolution
A new job of "Delete Duplicate Background Data" is now available to be scheduled to run in the backend ( Provisioning.). This job is used to delete duplicate background data records. When all columns are the same for multiple records, only the latest updated record is retained. Once the job is done, an e-mail notification is sent to the Job Owner.
Its important noting that this won't work with attachment blocks, as even if you run the same import job twice, currently the attachments will have different id each time they are imported, which will make them be considered different entries.
This job requires to be scheduled either by a Support Representative, or an Implementation partner with access to Provisioning.
This job must be scheduled by a Support Representative or an Implementation partner with access to Provisioning. Note that this process does not apply to attachment blocks, as they are treated as different entries due to unique IDs.
Customer Action:
- As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner. If you're no longer working with an implementation partner, contact SAP Cloud Support.
Note:
If duplicates persist after running the job, it may be due to changes in the background element, such as removing fields, which affects the checksum calculation. In such cases, a database fix is required to adjust the checksum values before rerunning the job.
To proceed, provide the support engineer with the following information:
1. Company ID
2. Background element ID
3. Customer must provide written approval for our database Team fix from the backend.
See Also
Keywords
Delete Duplicate Background Data; Remove Duplicates; Duplicate Data; Duplicate Records; Background Portlets; Live Profile Import; background duplicate records are not deleted, "Delete Duplicate Background Data" does not work, background element, the same background element records, checksum calculation, no deletion , KBA , LOD-SF-EP-BGD , Background Elements , Product Enhancement
SAP Knowledge Base Article - Public