Symptom
When looking at the People Profile, Live Profile User Information Block cannot be edited.
Environment
- SuccessFactors Employee Profile
- SuccessFactors Employee Central
Reproducing the Issue
- Log into the instance, while Employee Central is Enabled;
- Go to People Profile;
- Try to edit fields in the Live Profile User Information Block;
- See that they are greyed out;
Cause
HRIS Sync is enhanced in the following ways to eliminate data discrepancy. If you are an Employee Central user, the fields in the Live Profile UserInformation block in Employee Profile will be read only.
Resolution
These fields can only be updated by the HRIS Sync process to ensure data consistency. If you are not an Employee Central user, nothing is impacted - that is, as long as you have the correct role-based permissions, you can still edit the information on the Live Profile User Information block in your profile.
Keywords
Cannot Edit Fields, Live Profile Fields Greyed out, Personal Info Fields , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-EP-PP3 , DO NOT USE [Use a sub component of LOD-SF-EP] , Problem