SAP Knowledge Base Article - Public

2791687 - Unable to Fetch Supplier Contact Using QueryContactIn Service

Symptom

Unable to fetch contact data that assigned to supplier using QueryContactIn service.

Environment

SAP Business ByDesign

Reproducing the Issue

Request:

<ContactSelectionByElements>
<SelectionByInternalID>
<InclusionExclusionCode>I</InclusionExclusionCode>
<IntervalBoundaryTypeCode>1</IntervalBoundaryTypeCode>
<LowerBoundaryIdentifier>XXX</LowerBoundaryIdentifier>
</SelectionByInternalID>
</ContactSelectionByElements>
<ProcessingConditions>
<QueryHitsUnlimitedIndicator>true</QueryHitsUnlimitedIndicator>
</ProcessingConditions>
<RequestedElements contactTransmissionRequestCode="1">
</RequestedElements>

"XXX" indicates supplier contact ID.

Response:

<ProcessingConditions>
<ReturnedQueryHitsNumberValue>0 </ReturnedQueryHitsNumberValue>
<MoreHitsAvailableIndicator>false </MoreHitsAvailableIndicator>
</ProcessingConditions>

Cause

II_QUERY_CONTACT_IN is defined to use query BUSINESS_PARTNER - ROOT -QU_BY_RL_CP_OR_CP_CUST (Query By Role Contact Person Or Relationship Is Contact Person For Customer), which has customer and not supplier context.

Resolution

This is an expected system behavior.

Keywords

QueryContactIn;Supplier , KBA , SRD-MD-BP , Business Partner , Problem

Product

SAP Business ByDesign all versions