Symptom
- Report to Track User Notifications Sent Through EC Alerts and Notification Job
- Do we have an existing report that can fetch the email IDs of users who have received emails through EC Alerts and the Notification Job?
If not, is it possible to generate or run a report specifically for EC Alerts and the Notification Job?
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Employee Central
Cause
You inquired about the reporting capabilities for EC Alerts and Notifications. Currently, it is not possible to report against Employee Central alerts and notifications. This limitation means that there are no available reports to fetch details or statistics related to these alerts and notifications.
Resolution
Currently, there is no report available to track user notifications or to fetch the email IDs of users who have received emails through EC Alerts and the Notification Job.
You inquired about the reporting capabilities for EC Alerts and Notifications. Currently, it is not possible to report against Employee Central alerts and notifications. This limitation means that there are no available reports to fetch details or statistics related to these alerts and notifications.
If you would like this capability to be available—either through a design change or as part of a future release—we request you to please raise an enhancement request for this requirement.
You can submit an enhancement idea using the SAP Influence Tool at:
https://influence.sap.com/successfactors
For detailed steps on how to raise an enhancement request, please refer to KBA 2090228 - How to submit enhancement request.
FAQ - Additional Information
Q) Where can I get Guide?
A) Guide: Implementing and Administering Workflows in Employee Central
Chapter: Job Execution Overview and Examples of Handling Old Pending Alerts in Different Scenarios
See Also
- 2090228 - How to submit enhancement request.
- 2315275 - Employee Central - Workflows & Alerts
- 2757863 - Manage Alerts and Notifications tool
- 2156278 - How to Set Up EC Alerts and Notifications Using Business Rules
- 2757243 - How To Create Termination Reminder Alert Rule
- 3322740 - How To Create Alert Rule For Custom Probation End date Field in Employment Details
- 2697132 - EC Alerts: How to correct stored Alert after the Business Rule has been changed
- 2677124 - EC Alerts: System Logic for when a saveAlert Rule is Removed or Changed
-
2799601 - EC Alert Job with specify date
-
2079915 - About Workflow reporting - Employee Central
- 2376402 - Reporting on Activity Log for Workflow Changes / Manage Workflow Request - Advanced Reporting
- 2274688 - How to report on Workflow Information? - Employee Central / Canvas Reports / Story Reports
Keywords
Alerts and notification report, report, EC alerts and notification, email id. , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Product Enhancement
SAP Knowledge Base Article - Public