SAP Knowledge Base Article - Public

2792572 - Workflow Rule with Timing Scheduled Does Not Have Option for Notification Action

Symptom

You are creating a workflow rule with timing equal to scheduled, but when navigating to the Step 3, Define Actions, you cannot find the option Notification.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Workflow Rules option.
  3. Click on New.
  4. On Steps 1, Enter Basic Data, select Timing as Scheduled.
  5. Click on Next until you reach Step 3, Define Actions.
  6. See that on the dropdown for Rule Type, you do not have the option Notification.

Cause

The Notification rule type contains its own method of scheudling and timing. You can use the timing of the rule as On Every Save on the Step 1, Enter Basic Data, and then control when the Notification will be sent on the Step 3, Define Actions.

Resolution

This is the expected system behaviors. For Notifications, the method of controlling timing is slighlty different.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

Keywords

KBA , LOD-CRM-WKF , Workflow , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions