Symptom
You have used an Activity Plan to automatically add a Survey (or Task) to a Business Object (i.e. a visit). After the Survey is added to a new visit, you change the conditions in the Activity Routing Rule so that the Activity Routing conditions are not met anymore for the recently created visit. Hence, you now expect that the Survey to be removed from the visit.
Environment
SAP Cloud for Customer
Reproducing the Issue
The following steps are only an example. The same behavior can happen in other business objects.
-
Go to the Activity Planner work center.
- Go to the Activity Plan view.
- Click New and Open.
- In the Surveys facet, add a survey.
- Go to the Activity Routing Rule view.
- Click New and Open.
- Add some conditions in the Conditions facet.
- Add the Activity Plan to the Activity Plans facet.
- Go to the Visits work center.
- Go to the Visits view.
- Click New.
- Edit the Visit so that it matches the conditions in your Activity Routing Rule.
- Click Actions > Refresh visit.
- RESULT: The survey in the activity plan is added to the visit.
- Go back to the Activity Routing Rule and change the conditions.
- Go to the Visit and click Actions > Refresh visit.
RESULT: The survey that was added in step 14 is not deleted.
Cause
Routing Rules only add surveys, do not delete them.
Resolution
It is a new requirement that the system checks all previously added surveys and delete the ones that have not been answered yet.
You can manually delete the survey clicking the bin icon if desired.
See Also
- KBA 2714596 - When You Create a Survey, and Add it to an Activity Plan Which Dates are Set in The Future, This plan cannot be added to a Routing Rule
- KBA 2753358 - Tasks and Surveys Are Not Added From Activity Plan Within a Ticket
- KBA 2738997 - Surveys and Tasks are Not Automatically Assigned to Sales Quotes From an Activity Plan
- KBA 2728005 – There is no Check within the opportunity for mandatory Surveys/Tasks in an Activity Plan
Keywords
survey, task, delete, activity plan, routing rule, , KBA , LOD-CRM-ACT-ROT , Activity Routing , LOD-CRM-ACT-VST , Visit Planning , How To