Symptom
- Default email notification gets triggered although we have configured a custom email notification.
- Why is the default email notification template being sent to users even when a custom email notification has been setup?
- A custom Document Generation Template email was created to be sent to users but the system defaults to a standard email template.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Cause
The user's locale and language settings do not match the template.
Resolution
- When the email is being generated, the user's language and locale are used to create the information contained within the email.
- If there is no language template for the user's locale, the default template will be sent in the email instead.
- To resolve this issue either create a template with a locale that matches the user's current settings or change the user's locale to match the language field of the email notification template.
View:
- If you're uncertain of the user's locale, export the User Data File to find their current setting.
- For futher information see 2395445 - Default Locale | How to control the user language in SuccessFactors
See Also
- 2269945 - List of Supported Languages with Locales (BizX)
- 3115662 - Is It Possible to Map Custom-String field to EP standard Field defaultLocale
- 2380278 - How to set the Default Locale for a User in the Add New Employee Wizard
- 2395445 - Default Locale | How to control the user language in SuccessFactors
- 2269945 - List of Supported Languages with Locales (BizX)
Keywords
Success Factors, EC, workflow email, e-mail , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem
Product
SAP SuccessFactors Employee Central all versions