Symptom
Your workflow rule does not work as expected when you use the timing 'On Create Only'.
Environment
SAP Cloud for Customer
Reproducing the Issue
The same is true for many options. As example, you can have a workflow rule for the BO: Sales Orders, On Create Only. As Condition you are using Status=Open. Your plan is to have a field update triggered.
Cause
On Create Only: the rule is applied at every Create of the business object instance.
During creation, the object does not yet have a status. The status will be triggered on the save only. At creation stage, this workflow rule cannot be called.
Resolution
Change the creation time to be after creation: scheduled.
See Also
SAP Cloud for Customer Help Portal: Configure Workflow Rules
Keywords
KBA , LOD-CRM-WKF , Workflow , SRD-CC-BTM , Business Task Management , How To