SAP Knowledge Base Article - Public

2794159 - Mismatch in Number of Records Exported from Custom Object and Customer OWL

Symptom

Mismatch in number of records exported from custom object created from Customer BO and the data displayed in Customer OWL(UI).

Reproducing the Issue

  1. Go to workcenter Data workbench
  2. Go to Export View
  3. Select your custom object 
  4. Export all data

You notice that the number of records exported from Data workbench and that from the Customer OWL are different.

Cause

The data from the custom object would contain all the root level data including Customer, Individual Customer and also marketing leads as explained below.

Resolution

The difference between the standard service ie. Customer and the custom object created from Customer BO is due to the "MarketingLeadIndicator" in ROOT node of BO "Customer".

The export from the custom object also contains marketing leads. Each time you create a lead there is a customer created in background with LifeCycleStatusCode = In Preparation and MarketingLeadIndicator = X.

Note that the "marketing-lead-customer" is never shown in the Customer OWL or in the Odata service : Customer but internally filtered out. This account will appear in the OWL and in the Odata service if the lead gets converted.

Thus you might have to add a new filter criteria MarketingLeadIndicator <> X and LifeCycleStatusCode <> In Preparation to get the same results.

Also, the custom object would contain Individual Customer records.

Keywords

Customer, Data workbench , Export, MarketingLeadIndicator , KBA , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions