SAP Knowledge Base Article - Public

2794265 - Fiori - Recurring Time-Off Requests Causes Issues with Take Rules

Symptom

  • With the new Time-Off UI, the recurring absence option is enabled in Employee Self-Service.
  • This makes certain take rules not to work as expected.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employe Central - Time Off

Reproducing the Issue

Rule scenario:

An error message should be raised if you are requesting leave 10 days in a row before the balance is fully used. It should also appear if the balance after the leave request is less than 10 days.

Example:

  1. The user has 18 days Annual Leave balance and not fulfilled the requirement for 2019.
  2. If you try to request an Annual Leave of duration of 9 days, the systems blocks you, as you haven't already fulfilled the requirement and won't be able to do so because balance after the request is less than 10 days.
  3. If you add a request of 1 day that recurs at least 9 times, which leads into a balance of less than 10 days, the system doesn't block you, which means that the legal requirement of at least one single request of 10 or more days long request is not fulfilled.

Cause

  • For every absence the take rule is executed independent of the other ones.
  • If you are using a take rule based on balance, existing absences and so on, that reads information from database, and other recurring absences created in parallel are not taken into account. Therefore, such take rules will not work for recurring absence.

Resolution

The solution is to disable creation of recurring absence in the Time off ESS UI so that such take rules are still functioning correctly in ESS scenario.

Keywords

TIM-8280 TIM-9067 recurring absence take rule with recurring absence new time off ESS UI , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central 1902 ; SAP SuccessFactors Employee Central 1905 ; SAP SuccessFactors Employee Central 1908 ; SAP SuccessFactors HCM suite all versions