Symptom
- No emails appear when the new feature 'Message Center' is enabled
- Message shown "You have no messages"
Environment
SAP SuccessFactors Recruiting
Reproducing the Issue
- Enable Message Center as per section Enabling Email Correspondence and Message Center from the Implementation Guide.
- Go to Recruiting > Message Center
- No Emails in list > 'You have no messages'
Cause
Some RBP Permissions are not enabled
Resolution
- This issue is caused by a misconfiguration related to the permissions.
- Since RCM uses XML permissions, the objects related to RCM needs to be marked as non-secure. Add the following permission to your users:
- Manage Permission Roles > [Permission Role] > Permission settings > Permission... > Administrator Permissions > Metadata Framework > Access to non-secured objects
- Manage Permission Roles > [Permission Role] > Permission settings > Permission... > Recruiting Permissions > Odata API Candidate export
- Then once these permissions are enabled please carry out an oData MetaData Refresh
- To access and use Message Center, ensure to enable the EmailBrandTemplate permission for the relevant user.
- Please see the Accessing and Using Message Center section from the Implementation Guide for further details.
- If the issue still remains please open a Support Case.
**Alternatively, please use Upgrade Center as per the Release Notes which will avoid having to implement additional configuration.**
Note: The recruiter will see only his own email threads with candidates, so no threads started by other users will be visible.
Keywords
sf, success factors, RCM, Email Center, E-Mail, EmailBrandTemplate, OData API Candidate Export, Access to non-secured objects, RCM-59263 , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To
Product
SAP SuccessFactors Recruiting all versions