Symptom
- Encounters the instance sync error "An error occurred while retrieving the instance pairing details" in the Instance Sync Wizard page of the Source instance
- Instance sync Error "The application encountered an unknown error" when generating an authentication token in the source instance -- unable to acquire the token
***Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.***
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
For error "An error occurred while retrieving the instance pairing details":
- Go to Admin Center > Tool > Instance Synchronization Wizard
- You will find error within the page
For error "The application encountered an unknown error":
- Enter the source instance
- Search for "Instance Synchronization Wizard"
- Click "Launch Instance Synchronization Wizard" or go through the Instance Synchronization Wizard tool from the beginning > Instance Synchronization Wizard opens
- Click "Add New Pair" -- Instance Pair Wizard opens with the Select Target Details step active on it.
- Select the target data center and target environment.
- Enter the target Company Id.
- Click "Generate Token" > The error appears
Cause
Component specific information is missing from the instance which causes the errors
Resolution
The first step is to check if the (1) Instance Synchronization feature and (2) Enable Generic Object (MDF) feature in the Company Settings in Provisioning is enabled for both souce and target instances. It's mandatory to have both features enabled on source and target.
After ensuring these features are enabled, perform a metadata refresh in both the source and target instances. To do so, follow steps below:
- Navigate to Admin center and search for the tool "OData API Metadata Refresh and Export".
- Click on the refresh button and wait for it to complete.
NOTE: RBP permission "Admin access to MDF OData API" under Metadata Framework needs to be granted in the target instance
In case you are pairing the instances to perform an Instance Refresh through IRT, please note that due IRT limitations refresh is not supported if the target is a production instance. Therefore, this warning will appears in case the target is a production instance.
See Also
2088055 - Instance Synchronization Feature Guide & need to know information - Platform
Keywords
Instance synchronization, instance sync, error, application error, instance pairing, unknown error, odata api metadata refresh and export, An error occurred while retrieving the instance pairing details, An error occurred , KBA , LOD-SF-PLT-IST , Instance Sync Tool , LOD-SF-PLT-IRT , Instance Refresh Tool , How To