Symptom
Contacts created with client-side Outlook add-in are not synchronized correctly to Cloud for Customer when no customer account has been referenced. Details like e-mail address, phone number and address are missing in C4C, although they have been entered in Outlook.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Create a contact in Outlook within the folder "SAP Cloud for Customer Contacts" with detailed information, for example, e-mail address, phone number and address.
- Add the contact to C4C without referencing the contact to a customer account and press Submit.
- After the automatic synchronization open C4C and go to Customer > Contacts
- Look for the created contact in the list and open it.
- The details which have been entered in Outlook are missing in C4C.
Cause
This problem occurs when the details entered in Outlook have been entered as business details. Business relevant details are not synchronized with C4C when no customer account has been referenced.
Resolution
Change the details in Outlook to be entered as personal details, as shown in the screenshot below:
The details are shown in C4C now in Customer > Contacts > Overview as "Personal Addresses".
Note: The information seen in the pictures above has been created for test purposes only and any matches related to personal data of real persons are purely coincidental.
Keywords
client-side, client side, outlook, add-in, add in, addin, synchronization, error, bug, contacts, contact details, missing, data , KBA , LOD-CRM-GW-OUT , Outlook , Problem