Symptom
An External Candidate Profile got purged, but the profile is linked to one or more active applications.
Environment
SAP SuccessFactors Recruiting Management
Cause
The possible explanation will be the "Non-Acceptance" of DPCS. The system cannot store candidate data without DPCS acceptance.
The condition of “Non Acceptance” overrides the setting related to the Inactivity time.
As a consequence, if a candidate has been forwarded to an application and the DPCS has not been accepted, the profile will be Purged after the “Period of NON-Acceptance of DPCS”. This will always happen even if the Candidate is linked to active applications.
It is possible to verify if the candidate accepted the DPCS via:
- Admin Centre → Data Privacy Statement
- Check "View Log" for the correct statement version
Resolution
The suggestion will be to use Invite to Apply in the process, or extend the Period of Non-Acceptance to minimize the occurrence.
See Also
2635179 - New Data Retention Time Management in Recruiting Management
Keywords
Candidate, Profile, Purged, Non-Acceptance, Data Privacy Statement, DPSC, Job, Application, active application, DRTM, DRM , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem
SAP Knowledge Base Article - Public