SAP Knowledge Base Article - Public

2796165 - When Creating An Appointment From Calendar "All-Day Event" Defaults To "Yes"

Symptom

An appointment created from the calendar Month view shows "All-Day Event" slider to "Yes".  You wish to have the "All-Day Event" option defaulted to "No".

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Log in to Fiori Client.
  2. Click on Calendar Icon.
  3. Select the Month View.
  4. Select any Date in Calendar.
  5. Click on "+" icon, select Appointment.
  6. Screen shows field "All-Day Event" slider defaulted to "Yes".

Cause

In calendar month view, if the Date is selected before creating appointment from"+" icon, the creation appointment screen will show "All-Day Event" defaulted to "Yes".

This is expected behavior.

Resolution

Please, follow these steps if you wish to create an Appointment from Calendar Month view with default "All-Day Event" slider option to "No".

  1. Navigate to Calendar.
  2. Select the Month View. (Please note: Do not select any date in calendar).
  3. Click on "+" icon. 
  4. Select appointment.
  5. Appointment screen will show "All-Day Event" slider defaulted to "No"

Keywords

All-Day Event, Calendar, Month View, Slider, Appointment, Yes, No, Option , KBA , LOD-CRM-ACT , Activities , LOD-CRM-CAL , Calendar Control , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions