Symptom
Requirement: Trigger a workflow if no change to spelling is made to a string field, but rather a case change.
Environment
Employee Central, Workflows
Reproducing the Issue
- You have a workflow configured on Personal information, to trigger workflow in case of change of first / last name
- You change first name field from "john" to "John" > no workflow is triggered / workflow is triggered but after approval the full name has changed to upper / lower case "JOHN".
Cause
You won't be able to trigger a workflow consistently based on such a change using our rules engine. We have no supported / documented rule functionality to fully support this requirement.
Resolution
Please log an enhancement if necessary via the community portal to introduce a rule function which will support such a change.
Keywords
trigger workflow if changing uppercase to lowercase, trigger workflow if changing lowercase to uppercase, are workflows case sensitive, case sensitive workflow , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem