SAP Knowledge Base Article - Public

2799272 - No search records returned when admin search for Item by Title

Symptom

  • Admin can find item when searching by item ID only, but searching by title returens no results
  • If searching an item by tiltle, the result only returns when 'Search All Locales' is set as YES. 

Environment

SAP SuccessFactors Learning - All Supported Versions

Reproducing the Issue

  1. Admin navigates to Learning activies > Item
  2. When 'Search All Locales' is set as NO, enter Item title and click Search, no records is returned
  3. When 'Search All Locales' is set as YES, enter Item title and click Search, records are returned

Cause

The locale that the admin is using as a preference is not populated at item localisation level

Resolution

In order to resolve the issue you will need to do the following:

1. Check what is the active locale ID used by the admin

2. Navigate to learning activites > item > Find the impacted item > Item Details

3. Click World icon next to the item title

    4. Enter the title of the item for the locale used by admin or other locales admin wants to set up

    5. Click save. Then admin should be able to search by item title now

See Also

2548979 - Search by item ID return "No results match your search." in a Locale

2666339 - Item Title Localization - LMS

Keywords

item; locale; admin; search; type; LMS; title; no reulst; item details; item title; language. , KBA , LOD-SF-LMS-ITE , Items , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions