Symptom
You are trying to import Service Requests using Data Workbench, but you are receiving the error message below:
"Internal error; Create an SAP case"
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Data Workbench work center, in the Import view.
- Upload the template.
- Import the file.
- See the file import completed with errors in the Monitor view.
Cause
There are multiple reasons for this kind of error:
- One of the reasons for this error message is the date/time format used in the template for fields such as Requested_Start_Date, Requested_End_Date, Reported_On, Completion_Date and Completion_Due.The configuration of these fields in the metadata of the underlying service is Edm type datetimeoffset and that requires the use of the specific date/time format: YYYY-MM-DDTHH-MM-SSZ.
- Other reason could be ID fields with #N/A. This is not supported.
Observation: While completing a Data Workbench CSV template, it is always recommended to check the FieldDef file from the downloaded zip of the object you are importing, to see what are the supported formats of each field.
Resolution
Review the file and check if you are using any of the above mentioned fields in the template with a different format than expected.
Keywords
data workbench, Internal error Create an SAP case, service request import , KBA , LOD-LE-SRP , Obsolete: Please use LOD-CRM-SRP , Problem