Symptom
You have applied restrictions to certian users based on Sales Information but the Users are able find Accounts that has no Sales Data.
Environment
SAP Sales Cloud, SAP Service Cloud
Reproducing the Issue
Step 1: Assigning restriction to users based on Sales Data
Step 2: Accounts without Sales Data are visible to Users in Customers work center
Cause
This access might be caused by the fact that the account does not have one or more of the following:
– account team member
– territory
– assigned sales data
This means no access determination relevant data has been maintained in the business object instance (master data or business document). Therefore, the system is not able to identify any access restrictions. In this case, the system does not restrict access to the object instance at all and it is accessible by all users.
Resolution
There are two solutions possible for this requirement
Solution 1:
In order to achieve access restriction to this object instance at least some access relevant data must be maintained, for example, an account team member or a territory assignment.
Solution 2:
you can use the below scoping question.
1. Go to Business Configuration work center
2. Select Implementation Projects
3. Select Edit project Scope
4. Go to Questions section
5. Expand: Built-in Services and Support -> System Management -> User and Access Management
6. Select the Scoping question "Do u want to remove substitutions and authorizations for users whose validity date is in the past?"
7. Check the Overview section for the documentation
8. Then, you can scope this question
9. Complete the changes
Keywords
Account without sales data, All accounts are accessible , KBA , SRD-CC-IAM , Identity & Access Management , Problem