Symptom
When you are changing the Document Language within a Ticket and save the changes, the value of the field gets reset to the initial value.
Environment
SAP Cloud for Customer - Service
Reproducing the Issue
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Go to the Service work center.
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Select the Tickets view.
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Open Ticket 123 (123 represents the Ticket ID).
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Change the value of the field Document Language.
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Select the Save button.
The value does not get saved but is reset to the initial value.
Cause
The Source of the Ticket is an incoming E-Mail.
Resolution
This is the expected system behaviour.
The only use case where the Document Language can be changed is in Unassociated E-Mails.
Otherwise once the Ticket is automatically created and saved from an incoming E-Mail, this cannot be changed.
Keywords
Ticket Document Language Change Save Failed Reset Value , KBA , LOD-CRM-SRP , Service Request Processing , Problem