Symptom
You created a dynamic Target Group with a condition for Contact Permission = Allowed. You do not receive the expected results.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: you have existing, active contacts in your system. At least one contact ABC (ABC represents the contact's name) has Marketing Permissions maintained as 'Opt-In' for E-Mail.
-
Go to the Sales Campaigns work centre.
- Go to the Target Groups view.
- Create a new Target Group (TG).
- Check the
- Navigate to the Member Determination facet.
- For Contacts, create a condition: Contact Permission = Allowed.
- Save -> Activate -> Refresh to run the Target Group determination.
- Go to the Members facet.
- ABC was not added to the members of your TG.
Cause
While the contact has the opt-in option selected for E-Mails in Marketing Permissions, they do not have the field Contact Permission set as allowed.
Marketing Permission & Contact Permission go hand-in hand to help maintain privacy of communication channel (that is, e-mail, Fax, Telephone).
Contact Permission restricts access as per your customer's given consent to get contacted. When disallowed, you cannot, for example, send e-mails to that individual.
Subscription for a specific communication category can be prohibited by the communication channel within Marketing Permission for a specific person.
The permission settings for the corresponding country are set up within the system's Business Configuration.
With Marketing Permissions, you can control the information type the person receives.
Resolution
-
Go to the Customers work centre.
- Go to the Contacts view.
- Open ABC in edit mode.
- In the header, edit the field 'Contact Permission' and set to 'Allowed'.
- Save.
If the field is not available, contact your administrator to add it via Master Layout.
See Also
SAP Help Portal:
Keywords
Marketing Permission Contact Permission , KBA , LOD-CRM-MKT-TG , Target Groups , How To