Symptom
You select a default query to see when adding a product to a Sales Quote. However, you realize that this default query will also be displayed when adding a product to a Ticket.
Environment
SAP Cloud for Customer
Reproducing the Issue
These steps are only an example. The same can happen in other BO where Products are involved.
-
Go to the Sales work center.
- Go to the Sales Quotes view.
- Open a sales quote.
- Go to the Products facet.
- Click on Add.
- Click on the OWL next to the Products field.
- Click on Organize Queries.
- Select a Default query.
- Go to the Service work center.
- Go to the Tickets view.
- Open a Ticket.
- Go to the Products facet.
- Click on Add.
- Click on the OWL next to the Products field.
RESULT: You will see that the default query is the one that you defined for the Products view in Sales Quote.
Cause
Both windows are linked. Hence, you cannot define different default queries in the Products view in Sales Quotes and in the Products view in Tickets.
Resolution
This is the designed system behavior.
If you consider that the system should allow us to select different default queries for the different BOs, you would need to post this request in the SAP Hybris Cloud for Customer influence site: https://influence.sap.com
Keywords
default query, query, products, sales quote, tickets, BO, , KBA , LOD-CRM-SRP , Service Request Processing , LOD-LE-CQP , Customer Quote Processing , Problem