SAP Knowledge Base Article - Public

2802832 - Error "Hierarchy Does Not Exist" When Importing Product Category Hierarchies in Data Workbench

Symptom

You are trying to import Product Category Hierarchy into your Cloud for Customer tenant using Data Workbench, but the task fails with error message "Hierarchy does not exist".

Environment

SAP Cloud for Customer

Cause

The reason behind this is that you are trying to create the root level of the product hierarchy in this import. Currently, the system does not support creation of root product category through the Data Workbench.

Resolution

Please create the root product category manually by following the below instructions:

  1. Go to the Products work center.
  2. Select the Product Categories work center view.
  3. Click the New Hierarchy button.

There, you can maintain all mandatory and additional information you wish and create the root product category. Once that is done, you can expand the hierarchy using the Data Workbench functionality.

See Also

2791297 - Error: "Only One Top Category is Permitted; More Than One Top Category Exists" While Creating Product Categories Using Data Workbench

Keywords

Data Workbench, Product Category Hierarchy, Import , KBA , LOD-CRM-INT-DWB , Data Workbench , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , How To

Product

SAP Cloud for Customer add-ins all versions