SAP Knowledge Base Article - Public

2803683 - Application Error on PP3 When Benefits Section Loads

Symptom

An Application Error is encountered on PP3 when Benefits section attempts to load for some users.

Application error will contain fingerprint=dd0553706c2e3c9d84212e09543cf4e7d5efe664

Environment

SAP SuccessFactors Employee Central - Global Benefits

Reproducing the Issue

  1. Go to Profile of a User
  2. Scroll down to Benefits section
  3. Application Error 

Cause

This issue is occurring because of corrupted enrolment records. In some of the enrolments, the inactive records were deleted manually but still, the active records exist beyond the scheduled enrolment effective end date.

Resolution

The corrupted enrolments should be corrected and to do this export all enrolment records for the affected user and check if any enrolment is there without an inactive record. Then try inserting an inactive slice for the particular enrolment.

@Support Engineers - Please see internal memo for logs.

Keywords

Application, Error, PP3, Benefit, Benefits, Section, Load, Loading, User, Users, fingerprint=dd0553706c2e3c9d84212e09543cf4e7d5efe664, fingerprint, dd0553706c2e3c9d84212e09543cf4e7d5efe664, Profile, 1905, Release , KBA , LOD-SF-EC-GBF , Global Benefits , LOD-SF-EC , Employee Central , LOD-SF-EC-PP3 , People Profile (PP3) , Problem

Product

SAP SuccessFactors Employee Central all versions