Symptom
- The runtime filter fields that were added to the query do not show up in the Filter Summary screen when the report is previewed Online.
- In ORD/Canvas Admin > User Maintenance, the Accesibility setting is On for the affected user(s).
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
-
SAP SuccessFactors Reporting and Analytics
-
Online Report Designer / Report - Canvas
Reproducing the Issue
1. Create a new report and add a list component
2. Within the list component, create a query in Detailed Reporting Live Data, for example, and add Runtime Filters
3. Save the query
4. Preview the report page.
Result: Notice that the Filter Summary window does not display any field for filter selection
Cause
The Detailed List query Component does not currently support an accessible version of the "Runtime Filter Panel".
Currently, accessibility-related issues are not being addressed in WFA legacy tools.
Resolution
This is a current limitation.
Please consider disabling the Accessibility setting by editing the user profile in User Maintenance.
You can also change the setting from BizX so that when the user sync to the ORD profile runs your changes won't be reverted, see KBA
2820573 - Accessibility settings are getting enabled automatically for some users - Online Report Designer
Keywords
WFA-6741, filter panel blank, runtime filters not saved, runtime filters missing, run time filters, ORD filters not available , KBA , runtime filters not populating , LOD-SF-ANA-ORD , Online Report Designer , Problem