Symptom
Standard field is grayed out in Basic Search Fields in Adaptation.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login to Cloud for Customer.
- Go to any Work center.
- Select Start Adaptation.
- Hover over the list view and select data set.
- Click Add and select Basic Search Fields.
- Here you will be able to see the list of fields that can be added to the basic search.
You see that standard fields are visible but some standard fields are grayed out or cannot be edited.
Cause
This is because the standard field which we want to enable in Modify Basic Search is not added in Advanced Filter.
Resolution
- Go to Advanced Filter.
- Select Start Adaptation.
- Select the Advanced Search icon
- Hover over the Advanced Search Pane view
- Add the field which we want to be in Modify Basic Search using Add field option in adaptation.
This behavior is applicable for PDI and KUT extension fields as well.
See Also
Keywords
Modify Basic Search, Standard Field, Grayed out , KBA , standard field , modify basic search , kut , pdi , extension fields , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions