SAP Knowledge Base Article - Public

2804753 - Unable to Add Standard Field in Modify Basic Search

Symptom

Standard field is grayed out in Basic Search Fields in Adaptation.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login to Cloud for Customer.
  2. Go to any Work center.
  3. Select Start Adaptation.
  4. Hover over the list view and select data set.
  5. Click Add and select Basic Search Fields.
  6. Here you will be able to see the list of fields that can be added to the basic search.

You see that standard fields are visible but some standard fields are grayed out or cannot be edited.

Cause

This is because the standard field which we want to enable in Modify Basic Search is not added in Advanced Filter.

Resolution

  1. Go to Advanced Filter.
  2. Select Start Adaptation.
  3. Select the Advanced Search icon
  4. Hover over the Advanced Search Pane view
  5. Add the field which we want to be in Modify Basic Search using Add field option in adaptation.

This behavior is applicable for PDI and KUT extension fields as well.

See Also

  • 2436570 - Basic search by extension fields does not return any results
  • 2784351 - Fields In Basic Search for Accounts
  • 3038170 - Advanced Search in Account Does Not Show Records When Searched With City

Keywords

Modify Basic Search, Standard Field, Grayed out , KBA , modify basic search , standard field , extension fields , kut , pdi , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions