Symptom
When adding Custom Competency via Manage Templates, the localized competencies are not displaying. For example, the competencies that display are just for English locale even when the instance and user locale are already set to a different language.
Environment
SAP SuccessFactors Performance Management
Reproducing the Issue
- Go to Admin Center > Manage Templates > [Select the PM template].
- Select the Competency section. Check Custom as Section Type.
- Click Show advanced options...
- In Custom Competency defined, click Add Another. The competencies listed are only for English locale even though the instance and user locale are already set to a different language.
- Go to Admin Center > Form Template Settings > [Select the PM template]. The template Locale is set to the user's locale.
- When checking the Competency Library, there are Competencies configured for the user's locale.
Cause
The competency language will display based on the locale or Form Language of the Performance template selected in Provisioning.
Resolution
Please open an incident with Product Support to check the template locale in Provisioning and request it to be changed to the desired language. Please also ensure the above steps are followed to verify if your issue is due to incorrect locale selected for the template.
See Also
2436341 - Manage Templates - Custom Competency - Performance Management
Keywords
custom competency, competency language locale , KBA , LOD-SF-PM-FAM , Competencies Behaviors Families and Roles , Problem