Symptom
Time Off request shows as Approved in Time Off Overview and Time Account Postings, however, the associated workflow request remains 'In Process'
Environment
SAP Successfactors Employee Central
Reproducing the Issue
This scenario is caused whereby employee times have already been requested in the system with status pending, and they are then approved by importing the same external codes with status approved. However, this will not change the Workflow status and it will remain 'in process' / 'pending' creating a data inconsistency.
Cause
Employee Time record Approval Status was manually updated from 'Pending' to 'Approved' in MDF UI (Manage Data) or via import.
Example:
- Employee time is pending
- customer changes approval status via import to approved
- Result: workflow is not completed
Resolution
The pending workflows must be approved via the UI. Customers should never update employee time status from PENDING to APPROVED via import. Instead they should confirm the related workflow. Otherwise, the employee time has status APPROVED but the workflow item still exists.
As confirmed by Workflow Engineering Team such a request to mass approve multiple workflows via script or otherwise is not supported. Workflows can be mass approved by managers (up to 100 in one click) via the 'ToDo: Approve Requests' Tile or by system admins via Manage Workflow Requests. An enhancement request (TIM-615) is currently open to prevent this scenario from happening in future.
Keywords
Time Off, Workflow, In Process, Approved, Employee Time, Approval Status, workflow stalled , KBA , tim-967 , tim-615 , ect-89500 , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-TIM , Time Off , Problem