Symptom
You have added via adaptation mode the field Industry to the Convert to Account and Contact or Associate to Account and Contact screen in the Leads. You maintain a value in this field. However, when the lead is being converted, the field Industry appears empty
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Go to the Leads view.
- Open a lead which has not been converted yet.
- Enter a value into the Industry field.
- Click on Actions > Convert to Account and Contact or Associate to Account and Contact.
- Note that the value in Industry is not passed over.
- Select a value for this field in the Convert screen.
- Click on Save and Open.
The Industry field in the account is empty.
Cause
Convert/Associate to Account & Contact Screen:
This screen has as entry point and leading Object the Business Object "Business Partner" (Representing the Instance of the Contact). Hence when you add via Key User Tools the field "Industry", you will add the Field Industry of the Contact --> This is however empty and not used. In the Lead Instance the Industry of the Customer is shown. Unfortunately it is at the moment not possible to add the field "Industry" of the Customer into the screen "Convert to Account & Contact".
The behaviour is different in the Convert to Account Screen:
This screen has as entry point and leading Object the Business Object "Customer". Hence we you add via Key User Tools the field "Industry", you will add the Field Industry of the Customer. However, technically the Industry for Account in Lead is already stored in the Account. Hence there is also no copy from Lead to Account, when Converting a Lead to an Account.
Resolution
We are evaluating if the field Industry of the Customer can be added to the Convert to Account & Contact Screen in a future release, and we will disable the field "Industry" from Key User Tools in the screen "Convert to Account & Contact" as it does not make sense to be added. We cannot provide any timeframe for the above.
There is a standard field 'Industry' available at Lead screen under 'Account Information' section which you can add to the UI; any value added there will automatically be transferred when an account is created.
See Also
2568923 - Fields are Blank or Greyed Out When Converting Or Associating Lead to Account or Contact
2558370 - The Fields Are Read-Only When Converting a Lead to an Account
Keywords
Account ; Lead; Leads ; Convert; Associate ; Contact ; Industry; Add Other Fields; , KBA , LOD-CRM-LM , Lead Management , How To