SAP Knowledge Base Article - Public

2806337 - Extension Field Value Disappears after Adding Account in Manual Customer Invoice Request

Symptom

You created an extension field in the Customer Invoice Request screen, after entering a value in the extension field, when you add the Account in the New Manual Invoice Request system overrides the value of the extension field and it becomes blank.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Select New Manual Invoice in the Common Tasks.
  3. In the opened window, go to the General tab, you included an extension field, enter a text value in the field.
  4. Now enter the Account details.
  5. You can see that the extension field value is set to blank.

Cause

For the extension field you have added the extension scenario :

Account - General Information to Invoice Request - General Information -> Business Partner - General Information to Customer Invoice Request - General Information

which means whenever the Account is added in the New Manual Invoice screen , the extension fields in turn calls the Account Master Data details and the data is overridden. Hence after entering the value in the extension fields when you add the Account in the New Manual Incoice screen the value disappears as the system reads the Account detail values from the Account master and in this case for the Account under General Information tab there is no extension field found. Thus the field value becomes empty.

Resolution

In order to resolve the issue, include the extension field & text value in the Account master data according to your need or enter the value of the extension field after the Account details are entered in the New Manual Invoice screen or deactivate  the extension scenario which you have added.

If the extension field value needs to be entered manually all the time then you can remove the extension scenario using the following steps :

  1. Go to the Customer Invoicing work center.
  2. Select New Manual Invoice in the Common Tasks.
  3. In the opened window, select Adapt -> Enter Adaptation mode ->then Edit screen.
  4. Select the section General Information -> Extension fields tab, select the extension field which you have created and select the Further Usage link.
  5. In the opened window, go to the Extension Scenarios tab, in the second table, choose the extension scenario and select the Deactivate button.
  6. Save and publish the extension field changes.

In case, if for a Account the extension field value is constant then you can maintain the field value in the account master data. The steps to be followed are :

  1. Go to the Account Management work center and Accounts View.
  2. Select the Account ID and select Edit -> General tab.
  3. In the opened window, select Adapt -> Enter Adaptation mode ->then Edit screen.
  4. Select the section Account, select Extension fields tab, you will see the extension field there.
  5. Make the field visible and publish it.
  6. Later maintain values in the extension field and perform Save.
  7. Then, whenever you create a New Manual Invoice and the Account ID is entered, the system will by default enter the values in the extension field.

Keywords

Extension Field disappears; Invoice Request; wrong value , KBA , extension field , manual invoice request , extension field value disappear , AP-CI-CI , Customer Invoice , Problem

Product

SAP Business ByDesign all versions