SAP Knowledge Base Article - Public

2806554 - An Extension Field Added is Showing as Single Line in the Ticket Header

Symptom

It is not possible to show extension field text content as box, but it displays as a single line.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to Service work center.
  2. Go to the Tickets view.
  3. Search and open ticket LMN (where LMN represents the ticket name).
  4. Click on Adapt->Edit Master Layout .
  5. Click on add field and select button New Field.
  6. In the New field window, enter the type as Text and sub type as Extended text and apply.
  7. End Layout changes.
  8. You can see the newly added field is showing as single line.

Cause

Irrespective of you selecting the sub type for new field as short text, medium text, long or extended text - it will always show it as single line. However base on sub type you have the value within the field with more characters.

Resolution

If you want to display the new extended field as box, you can select the type as formatted text.

  1. Go to Service work center.
  2. Go to the Tickets view.
  3. Search and open ticket LMN .
  4. Click on Adapt->Edit Master Layout .
  5. Click on add field and select button New Field.
  6. In the New field window, enter the type as Formatted Text and apply.
  7. End Layout changes.

Now you can see the newly added field is showing as box.

Keywords

New Field, content , box , KBA , extension field , formatted text , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer add-ins 1905 ; SAP Cloud for Customer add-ins 1908 ; SAP Cloud for Customer add-ins 1911 ; SAP Cloud for Customer core applications all versions