Symptom
You set up a Renewal for Contract with multiple line items. During renewal for each line item a new recurrence pattern is created.
Environment
SAP Business ByDesign
Reproducing the Issue
- Create a contract ABC with renewal rule and 2 line items (ABC represents the contract ID)
- Create an invoice schedule for both line items.
- Assign the invoice schedules to one Recurrence Pattern.
- Release the contract and wait for items to be renewed.
Each Line Item creates a new recurrence pattern, which is identical to the originally used recurrence pattern.
- Navigate to the Sales Order work center.
- Open the Contracts view.
- Open Contract ABC.
- Navigate to the Pricing and Invoicing tab.
- Select the Invoice Schedule subtab.
- Edit Invoicing Time Frame.
You can see the original recurrence pattern and a recurrence pattern for each renewed line item.
Cause
The original Contract has an Invoice Schedule with a recurrence pattern.
The invoice schedule created with this recurrence pattern was deleted/modified which resulted in an individual entry.
During the renewal, a new recurrence pattern is created for each line item, which contains the information from the original recurrence pattern.
However, since there is an individual date that does not have this recurrence pattern, this entry is copied over to the renewed contract with the same date, percentage, and amount.
If the re-determined List Price in the new Contract is greater than the List Price in the original Contract, the new Contract will be created with 2 dates in the Invoice Schedule:
- Invoice Schedule with the same Invoice Date as in the original Contract, Percentage the same as in the original Contract, Amount the same as in the original Contract and no value in the Invoicing Time Frame Column.
- Invoice Schedule with the recurrence pattern maintained in the original Contract, with the Invoice Date adjusted to the new Contact duration, Percentage and Amount as remaining balance between re-determined List Price and List Price in the original Contract, and the name of the Invoice Time Frame that was created in the original Contract in the Invoicing Time Frame Column.
If the re-determined List Price in the new Contract is lesser than the List Price in the original Contract, the new Contract will not be created and an error occurs in the Renewal task:
Item AA: Sum of dates' amounts XX,XX EUR exceeds the item's amount YY,YY EUR (AA represents the line item number, XX,XX EUR represents the List Price determined after the redetermination, YY,YY EUR represents the List Price in the original Contract).
Error occurred while saving the changes
You can check the renewal task with errors as follows:
- Go to the Sales Orders work center.
- Select the Contracts view.
- Select automated Tasks with Errors in the drop down list
- Select the Task Automatic Renewal of Contract XYZ
- Open the Application Log
- In the General tab you can see the respective error.
Resolution
This is the current system behaviour.
If you are using a renewal rule for Contracts with Invoice Schedules you need to ensure that the Invoice Schedule is created with a recurrence pattern and the recurrence pattern is not manually changed in the Invoice Schedule.
Keywords
Contract, Vertrag, Recurrence Pattern, Wiederholungsmuster, Rechnungsterminplan, Invoice Schedule , KBA , AP-CCP-CC , Customer Contract , Problem
SAP Knowledge Base Article - Public