Symptom
When trying to perform an User Permanent Purge, customer is receiving the message: User ID list provided is not correct.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to Admin Center > Data Retention Management
- Click on User Permanent Purge
- Create a file based on the template including the User ID
- Submit the request
- Receive the notification that User ID list provided is not correct
Cause
The user you are trying to purge was not soft purged before.
Resolution
To perform a User Permanent Purge on an user, you need to make sure that user was previously soft purged. If you are still seeing the user in the User Data File as 'inactive', this means that the user was not soft purged yet.
Please proceed with the soft purge again, and after this process, try to proceed with the permanent purge again. More details about how to proceed with the soft purge are available in the KBA in the see also section of this document.
See Also
2088065 - Data Retention Management - Purge Data - Platform
Keywords
Purge, Permanent, User ID, UserID list provided is not correct, Unable, error, user , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem