Symptom
In a report based on the data source All Activities (technical ID CODACTU) which includes all day appointments, some of the entries do not have their start and end times on the same date despite being an all-day event.
Environment
SAP Cloud for Customer
SAP Business ByDesign
Reproducing the Issue
- Go to the Analysis work center and select the Reports view.
- Open your report, for example Activity Analysis.
- In the view, add the activity and the fields Calendar Day, Start Date and End Date.
- You may notice that for some all-day events, these fields show the wrong date.
Cause
When you maintain the start and end dates, they will be saved in a specific time zone. However the fields Calendar Day, Start Date and End Date, always shows the date/time data in terms of UTC (Coordinated Universal Time) as the analytical servers are maintained with UTC.
Resolution
This is the standard behavior of the system.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Appointment, all day; DOC_REP_DATE, UTC, Time Zone , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-CAL , Calendar Control , Problem